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What is the Virtual Workspace? 
The Virtual Workspace (Figure 1) is Towson University's new web-based remote access product that 

allows TU users to remotely access several software programs from virtually any computer anywhere 

with an Internet connection and a browser.  You can be on campus or off, at home or in a hotel—it 

doesn’t matter.  In addition to having access to email and some of the more commonly used work 

programs in the Virtual Workspace you also have the ability to add new documents, and access and 

modify files on your network drives (H: and O:).   

You can access the Virtual Workspace by typing the following URL in the browser’s Address bar: 

http://virtualworkspace.towson.edu  or  http://vw.towson.edu  

 

 

 

 

 

 

 

 

 

 

 

 

Why is the Virtual Workspace Accessed Via a Web Page?  
Towson University has chosen to implement the Virtual Workspace purely through the Web Interface 

in order to keep the experience consistent for all users, maximize security, and make access easy 

and simple.  This implementation is the most secure model that is available and therefore the best 

for all TU computing needs. 

Can Students Access the Virtual Workspace? 
As of February 2007 TU students can not access the Virtual Workspace.  OTS is attempting to seek 

funding to allow students to access the Virtual Workspace and has hopes of eventually installing 

many of the software packages that students use in the campus computing labs.  If you would  

like an update on this matter, please email Mark Addy at maddy@towson.edu. 
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 VIRTUAL WORKSPACE: FREQUENTLY ASKED QUESTIONS (FAQS) 

How Do I Connect to the Virtual Workspace? 
You can connect to the Virtual Workspace from any Internet connection using a Browser.  In other 

words, you can access the Virtual Workspace from inside the Towson University network, from your 

computer at home using either dial-up or a broadband connection, or from a hotel or shared kiosk 

machine at a conference center or library.  You can access the Virtual Workspace here:   

http://virtualworkspace.towson.edu  or  http://vw.towson.edu  

You may need to download and install an additional browser component.  In this case, you will see a 

download software notification in the Message Center (the lower part of the Virtual Workspace Log In 

screen).  The download is listed as MetaFrame Presentation Server Client for 32-bit Windows.  

Click the link to install the browser component. 

Note: You will need Administrative rights to install software on your work computer.  Please call the 

Help Center at 410-704-5151 to get temporary admin rights if installing software on a TU machine. 

Note:  Mac Users will need to select the “Citrix Client download site, select Clients downloads, and 

then scroll down to Macintosh and select OS X or PowerMac. 

Which Browsers are Recommended to Access the Virtual Workspace? 
• For Windows Users: Internet Explorer 6.0 or higher. 

• For Mac Users: Mozilla FireFox 1.5.0.7 or higher (Note: Safari will not work) 

 Mozilla is available for download at: http://www.mozilla.com/en-US/firefox/ 

 Select the “Other Systems & Languages” link and scroll down to the English MAC version 

What Do I Need In Order to Access the Virtual Workspace From Home or 

An Off-Campus Computer? 
A one-time installation of a small browser component ("Citrix Web client") is needed before you can 

use Virtual Workspace. To install it, you will need to be an Administrator on the computer.  If you are 

not an Administrator, the installation will not work. You will need to either log into Windows using 

another account (one that has Administrator rights), then select "Run As Administrator" if 

prompted, or get help from the person who manages your computer system. 

 

If you are trying to use Virtual Workspace on a computer that is not yours (e.g. a PC in someone 

else's home or office, at a library, airport, or an Internet cafe) please keep in mind that you probably 

will not have Administrator rights and so you will not be able to install the software component 

needed to use Virtual Workspace.   

Note:  You are still able to get to your faculty/staff e-mail account through a web browser, provided 

the computer has an Internet connection: http://outlook.towson.edu 
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 VIRTUAL WORKSPACE: FREQUENTLY ASKED QUESTIONS (FAQS) 

What Programs are Available? 
The Applications page gives you quick access to Excel, Outlook, PowerPoint, Word and the towson 

Desktop.  From the Towson Desktop you can access all the programs listed below. 

• Microsoft Office 2003 which includes Outlook, Word, Excel, PowerPoint, FrontPage,  

Access, and Publisher. 

• Internet Explorer 7. 

• Adobe Reader 8. 

• Secure Shell Client. 

• PowerTerm Telnet Client. 

• AutoDesk DWG Reader. 

• PDFCreator 

Where Are All My Other Programs? 
You may not see all of your applications from your PC on the Virtual Workspace.  Included in your 

Virtual Workspace are the main programs you typically need when you are away from the office.  

Please see the What Programs are Available? FAQ on page 2 for the complete list of applications 

that are available through the Virtual Workspace. 

Why is the Start Menu Different in the Virtual Workspace? 
All users have reduced ability within the Windows XP desktop when using the Virtual Workspace.  

This is to avoid problems that might affect the whole Virtual Workspace environment. 

What is the Towson Desktop? 
The Towson Desktop (Figure 2, 1)  is your connection to the Virtual Workspace.  This connection  

provides a Windows XP desktop where you can access your email, create and modify documents and 

spreadsheets.  This Windows desktop is NOT the same desktop you see when you are working on 

your TU office computer. 
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 VIRTUAL WORKSPACE: FREQUENTLY ASKED QUESTIONS (FAQS) 

Can I Add Other Programs to the Virtual Workspace? 
No you cannot add other programs to the Virtual Workspace desktop.  Security restrictions do not 

allow users to add programs in order to curtail unknown application issues.  If you would like to re-

quest a new application installed on the Virtual Workspace, please contact Mark Addy at 

maddy@towson.edu.  Please include the application name, system requirements, number of users 

that will be using the application and what type of licensing the application uses. 

Can I Access or Save Files to My personal Hard Drive? 
Yes you can.  You can access or save files such as documents, spreadsheets, or pictures to your local 

hard drive.  To do so, either double-click the My Computer and navigate to the desired file location 

or open one of the applications, such as, Word or Excel, then click File > Open, select the hard drive 

from the top of the window and navigate to the desired file location.   

Can I Access My H: and O: Drives? 
Yes, you can.  Your H: and O: drive access is the same through the Virtual Workspace as when you 

are in the office.  Use the same procedure as above except select the desired drive letter in the My 

Computer or from the top of the Open dialog box.   

Can I Access My Cross Departmental Drives or Other Mapped Drives? 
Yes, you can.  However, you must first create a shortcut on your H: drive that points to the location 

of your cross departmental drive or any other network drive you need to access.  Follow the below 
instructions on how to create a shortcut: 

1. Log into the Towson Desktop in the Virtual Workspace 

2. Double-click the My Computer. 

3. Double-click the H: drive. 

4. Select File > New > Shortcut from the menu bar. 

5. Type the network path of the mapped drive and click on Next.  Example: \\gold\ots$ 

6. Type a desired shortcut name and click on Finish. 

7. A shortcut in your H: drive displays.  Double-click the shortcut to access that location. 

How do I Map a Local Drive in the Virtual Workspace? 
Your local drives from can be automatically mapped in the Virtual Workspace.  This is accomplished 

the first time you logon to the Virtual Workspace where you are prompted for access to local client 

files.  The settings described below, will allow the Virtual Workspace to map your local drives for 

read/write access and make the settings permanent in future sessions. 

1. In the ICA Client File Security dialog box, select Full Access (Figure 3, 1) and Never ask me 

again for any application (Figure 3, 2). 

2. When ready, click OK (Figure 3, 3) to apply the new settings and close the dialog box. 

What Are My Printing Options? 
You will be able to print from the Virtual Workspace to any locally attached printer, e.g. your printer 

at home. 
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 VIRTUAL WORKSPACE: FREQUENTLY ASKED QUESTIONS (FAQS) 

Why Does the My Computer Icon have a Planet Name in the Title? 
The planet name is the server name to which you are connected.  The planet name has been added 

to help expedite any troubleshooting issues or problems you might have on the Virtual Workspace.  

You can give this information to the Help Center while reporting issues which will help the Engineers 

solve the problem in a more timely fashion. 

Why is the Virtual Workspace Not Responding (Freezing Up)? 
The possible cause for a program delivered by the Virtual Workspace is freezing up can be one of 

many causes.  The most likely cause is that you lost your internet connection or the connection 

speed was reduced so the Virtual Workspace can not receive video data from the server.  The best 

course of action is to disconnect and reconnect to the internet. 

Does the Virtual Workspace Session Time-out? 
Yes, your Virtual Workspace session will time-out or get disconnected after 3 hours of no activity. 

What Does the Error “There is not enough free disk space” Mean? 
Users of the Virtual Workspace has 15 MB of available disk space.  This does not include the H: or O: 

drives.  Remember, the Virtual Workspace is not your office computer, so all important data should 

be saved to either your H: drive or O: drive and not the desktop. 

An "ICA Client File Security" Dialog Box Displays When I logon to the 

Virtual Workspace.  What Do I Do?  
In order to allow the Virtual Workspace to map to your local drives with full read/write access and 

make the settings permanent in future sessions, the settings should be set as shown in  Figure 3. 
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 VIRTUAL WORKSPACE: FREQUENTLY ASKED QUESTIONS (FAQS) 

What Do I Do If I Experience Issues With the Virtual Workspace? 
If you experience installation or software functionality issues within the Virtual Workspace, please do 

not try to fix the issue yourself.  Instead, please contact the Help Center at 410-704-5151 during 

business hours.  When calling the Help Center, please provide the following information which will 

help the support staff diagnose the issue: 

1. The name of the server you are accessing.  Each server will have its server name listed as part of 

the name of the My Computer icon located on the desktop.  If you run into issues please make 

note of this name. 

2. The name of the application, if any, that is causing you the issue and a short description of what 

happened when you experienced the problem. 

3. A screen shot of the problem, if possible.  To create a screen shot, press the Print Screen on 

the keyboard (typically located to the right of the F12 key), then open Word and select  

Edit > Paste from the menu bar.  Once the screen shot has been pasted in the Word document, 

your Help Center representative will provide the email address to which you need to send it. 

Why I Don’t See My Outlook Personal Folder in the Virtual Workspace 
To see your Outlook Personal Folders when using the Virtual Workspace, do the following: 

1. Click the Microsoft Outlook 2003 icon on the Applications page in the Virtual Workspace. 

2. If prompted by a Client File Security dialog box, please select Full Access and Never Ask Me 

Again. 

3. In Outlook, select File > Open > Outlook Data File… from the menu bar. 

4. Browse to your H: drive and locate your Personal Folder File (*.PST). If your file is stored in 

a different location, navigate to that location. 

5. Select the desired Personal Folders File (.pst) and click OK. 

6. You should now see your Personal Folder in the Folder List with the rest of your folders.  Note: 

you may need to switch to the Folder List view and you may also need to expand the Personal 

folder to see any sub folders within. 

Auto-Reboot Maintenance Schedule 
To keep the Virtual Workspace servers better maintained, the servers are scheduled to automatically 

restart once daily between 2:30 a.m. and 4:30 a.m..  If you are logged on to the Virtual Workspace 

during this time, your session will be terminated.  You can log back in and will be connected to  

another Virtual Workspace server. 

 

 


