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Microsoft FrontPage 2003 includes many Web components for users to add to their Web pages.  Web 
components are dynamic objects on web pages used to enhance the viewing experience of visitors to 
your site.  Through Web components, users can add a wide variety of 
features to their site.  This document will cover Web components 
such as scrolling text, hit counters, pictures galleries, search tools, 
and more! 

Dynamic Effects 
Dynamic Effects include marquees and interactive buttons.  Marquees 
are another name for scrolling text.  The text will fly across the 
screen at customized speeds and directions.  Interactive buttons can 
serve as links and can be customized to light up different colors.  To 
add dynamic effects: 

Marquee 
1. From the menu bar, click Insert (Figure 1, 1) >  

Web Component (Figure 1, 2). 

2. Make sure the first option, Dynamic Effects (Figure 1, 3) is 
highlighted on the left, and on the right, Marquee (Figure 1, 4) 
should be highlighted by default. 

3. Click Finish to insert the Marquee (Figure 1, 5). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The Marquee Properties window will now open.  Here you can customize the  
options for your Marquee. 

1. Enter the text to be displayed in the Text text-box (Figure 2, 1). 

2. Choose which Direction the text should move (Figure 2, 2). 

3. Decide what speed you want the Marquee to move: 

1. Dynamic Effects 

2. Web Search 

3. Spreadsheets and charts 

4. Hit Counter 

5. Photo Gallery 

6. Included Content 

7. Link Bars 

8. Table of Contents 

9. Top 10 List 

10. MSN Mapping  
Components 

11. MSN Components 

12. MSNBC Components 
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• Delay— how long do you want the text to remain on the screen. 

• Amount — how fast do you want the text to move (Figure 2, 3). 
4. Decide how you want the text to act under the Behavior category: 

• Scroll— text will travel across the screen, disappear, and repeat the process. 

• Slide— text will travel across the screen and stop. 

• Alternate— text will travel from one side, briefly stop, and move to the other side of the 
screen and repeat the process (Figure 2, 4). 

5. Place checkmarks in the boxes under Width and Height in the Size box if you wish to enlarge the 
text (Figure 2, 5). 

6. By default, the text will perform its assigned action continuously, until the user exists the page, 
to change this to have the text only move a certain amount of times, in the Repeat Box,  
uncheck the Continuously checkbox (Figure 2, 6). 

7. Click the drop-down arrow under Background color to choose a color to appear behind the text 
(Figure 2, 7). 

8. Click OK when finished (Figure 2, 8). 

 

 

 

 

 

 

 

 

 

 

 

 

 

Interactive Button 
Interactive buttons are small graphics users can insert onto their websites to serve as hyper-
links.  Interactive buttons can be setup to glow different colors when the cursor is placed on top of 
them.  To insert an interactive button:  

1. From the Insert menu click Web Component. 

2. Make sure Dynamic Effects is highlighted under Component Type. 

3. Under Choose an effect, click on Interactive Button and click Finish. 

4. The interactive button properties box will appear.  Make sure the Button tab is selected and 
choose a button style by clicking on different buttons and previewing them.  Use the scroll bar to 
scroll down and view all of the options (Figure 3, 1). 

5. Once you have button style selected, enter the text to be displayed on the button in the Text 
text-box (Figure 3, 2). 

6. Enter the URL of the page that opens upon clicking the button in the Link text box (Figure 3,3). 

7. Click the Font tab to edit the Font of the text displayed on the button.  Choose a Font, Font 
Style, and a Size (Figure 3, 4). 

8. Choose a color scheme for the button: 
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• Original Font Color— Color of font initially. 

• Hovered Font Color— Font color when the cursor is on top of the button. 

• Pressed Font Color— Font color after the button has been clicked on by the user (Figure 3, 
5). 

9. Choose where to align the Font inside the button Horizontally and Vertically (Figure 3, 6). 

10. Click the Image tab and preview your button.  Next, adjust the width or height if needed 
(Figure 3, 7). 

11. Finally, choose whether to make the button a JPEG image file or a GIF image file.  The JPEG  
format is a larger file and looks better.  The GIF is smaller and grainier (Figure 3, 8). 

12. Click OK when finished to insert your button (Figure 3, 9). 

 

 

Web Search 
Sometimes people can not find exactly what they are looking for on a Website.  In these cases, it 
may be easier to search the Website for an item.  Unlike Web searches, like Google or Yahoo, this 
Web search only searches through the Website, not the entire Internet.  To insert a Web search: 

1. Click on the Insert menu and choose Web Component. 

2. Under Component Type, click on Web Search, and under Choose a type of search, click on  
Current Web, if it is not already highlighted.  Click on Finish to continue. 

3. The Search Form Properties window will open.  Be sure the Search Form Properties tab is  
selected.   

4. In the Label for input text box, enter the text to be displayed next to the search on the  
website (Figure 4, 1). 

5. Identify how many characters the user may enter into the search by entering a number into the 
Width in characters text box (Figure 4, 2). 

6. Type in the Label for “Start Search” button text box what you want to be dis-
played on the search button (Figure 4, 3). 

7. If you wish to change the text to be displayed 
on the Reset button to something other than 
“Reset” do so in the text box, Label for 
“Reset” button (Figure 4, 4). 

8. Click OK to insert the Web search tool. 
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Spreadsheets and Charts 
Microsoft FrontPage spreadsheets and charts can be used to display information in an organized 
fashion.  Visitors to the Website can enter and change data in a spreadsheet and have the data be 
displayed in a chart or graph.  Three types are available: 

Office Spreadsheet 
Office spreadsheets can be inserted onto web pages to hold and display information.  
They can perform mathematical  functions, filter data, and export the data to Microsoft 
Excel.  To add an Office Spreadsheet to your webpage: 

1. Go to the Insert menu and choose Web Component. 

2. Under Component type, click on Spreadsheets and charts.  

3. Under Choose a control, click on Office Spreadsheet. 

4. The spreadsheet works similar to Excel.  Click on the Commands and Options button to access 
more features. 

Office Chart 
Office charts take data and make a physical representation of the 
data for people to see it more clearly.  The data can be typed into 
the chart upon creation, come from Microsoft Access, or come 
from a Web item such as the Office Spreadsheet.   

1. Go to the Insert menu and choose Web Component. 

2. Under the Component type choose Spreadsheets and 
 charts and under Choose a control, click on Office Chart. 

Three choices are available to serve as the source of the data.   

If you choose the first choice, Data typed into a data sheet: 

1. Left click to place a dot in the circle to choose Data typed in a 
data sheet (Figure 5, 1). 

2. Click on the Data Sheet button (Figure 5, 2) to manually 
enter data for creating a chart.   

3. Enter the data into the spreadsheet. 

4. Click on the Type tab to choose which type of chart you want to create (Figure 5, 3). 

5. Click on the X to close the window. 

If you choose Data from a database table or query: 

1. Left click to place a dot in the circle to choose 
Data from a database table or query. 

2. Click on the Connection button to set the database  
connection.  

3. Click the Edit button to connect to a file through Microsoft SQL Server, ODBC DSN, Oracle, or 
Microsoft Business Solutions. 

4. Click on the Type tab to choose a chart type. 

5. Click the X to insert a chart. 

If you choose data from the following Web item: 

You must include an Office Spreadsheet (See top of the page) or Pivot Table somewhere in the  
webpage.  

1. Click on the Ranges button to set the chart ranges. 

2. In the data range text box, type the range you want the chart to show from the spreadsheet or 
pivot table (Figure 6, 1).  For example, if the data in the spreadsheet is listed in the B2 square 
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and goes down and to the left to D4, B2:D4 would be the range. 

3. Choose whether to display the graph by reading the  
information by rows or columns (Figure 6, 2). 

4. Give each series a name by clicking on the series  
(Figure 6, 3), by default it will say Series1,  
Series2, etc.,  and renaming it in the Series name 
text box (Figure 6, 4). 

5. Click on the Type tab to choose a chart type. 

6. Click on the X to close the window and create the chart. 

Office Pivot Table 
An Office Pivot Table is an interactive component designed to 
analyze and summarize databases.  Office Pivot Tables display 
information in a list format.  To insert an Office Pivot Table: 

1. Click on the Insert menu and choose Web Component. 

2. Click on Spreadsheets and charts and on the right, click 
on Office Pivot Table. 

3. Click the link titled, Click here to connect to data to bring up the Commands and Options 
window. 

If you are connecting to a database: 

4. Make sure you are viewing the Data source tab under Commands and Options.  Under Get data 
 using, click on the circle next to Connection, to place a dot in the circle.   

5. Click the Edit button to select a data source. 

Hit Counter 
A hit counter is a graphic displayed on a Website which automatically counts the number of hits or 
visits to the site, and displays the number.  Hit counters allow webmasters to know how many people 
are visiting the site.  To insert a hit counter: 

1. Go to the Insert menu and click Web Component. 

2. Click on the fourth option down, Hit Counter, and use the scroll bar on your right to scroll to a 
hit counter you prefer.  Double-click on the hit counter you have chosen. 

3. Place a check mark in the box, by left clicking on it, if you want to reset the counter to zero. 

4. Place a checkmark in the second box to limit the number to a certain amount of digits.  Click OK 
when you are finished to insert the hit counter. 

Photo Gallery 
Photo Galleries provide users with options to display pictures in more effective formats.  Instead of 
going to the insert menu to place pictures on your webpage, users can add a Photo Gallery.  Photo 
Galleries are interactive and more professional looking.  Photo Galleries will even create thumbnails, 
smaller versions, of your pictures automatically.  To insert a Photo Gallery: 

1. Click on Insert and choose Web Component. 

2. Click on Photo Gallery and you are presented with four choices: 

• Horizontally— create a Photo Gallery with pictures, captions, and descriptions displayed   
horizontally.   

• Montage— thumbnails are displayed in a collage on the page.  Captions appear when the cur-
sor is rested over the image.  Descriptions are not available in this layout. 

• Slideshow— thumbnails are displayed in a scrollable row at the top of the page in this layout.  
When a thumbnail is clicked on, a large version appears underneath.  Captions and  
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descriptions are displayed under the larger version  
of the picture.   

• Vertically— produce a Photo Gallery with  
thumbnails, captions, and descriptions shown  
vertically. 

3. Select a style and click Finish to insert the Photo  
Gallery. 

4. Make sure the Pictures tab is selected and click on the  
Add button (Figure 7, 1). 

5. Choose whether the picture is coming from file (the com-
puter) or from Scanner or Cameras.  If the picture is 
coming from file, navigate to the picture, highlight it, and 
click Open. 

6. The picture will be added to the column on left.  The 
name of the file will be displayed.   

7. Users can click the Edit button to edit a picture.   
FrontPage contains tools for rotating, cropping, or  
adjusting the size of the picture.  To remove the picture from the Photo Gallery, click the  
Remove button. 

8. To change the position of pictures within the gallery, click on a picture to highlight it and click the 
Move Up or Move Down button.  

9. Type in a caption from your picture in the Caption text box (Figure 7, 2). 

10. Enter a description of the picture into the Description text box (Figure 7, 3). 

11. Repeat steps 4-11 to enter additional pictures into your gallery. 

12. The Layout tabs give users the option to change the layout even if pictures and other information 
have already been entered. 

13. Click OK to insert the Photo Gallery. 

Included Content 
Included content contains some time saving features.  To insert any of these options, go to the  
Insert menu, click on Web Components, and click on included content.  These options include: 

• Substitution— User can display the author, last changed, or URL information on the webpage 
automatically. 

• Page— Display one page’s contents on another page. 

• Page based on Schedule— Show content from other web pages on this page at a specific 
time. 

• Picture based on Schedule— Show a certain picture on this page at specific times. 

• Page Banner— Insert a graphical or text page banner. 
 

 

Substitution 
Click the drop down arrow and choose which option to insert.  
Click OK to insert the element automatically (Figure 8). 

Page 
Either type in a URL or click the Browse button to display the 
page contents. If you type in a URL, the page must be part of your Website. 
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Page Based on Schedule 
A page based on schedule gives you the option of having different Websites displayed at different 
times.  To insert a Page based on Schedule: 

1. Click Insert in the menu bar and choose Web  
Component. 

2. Under Component Type, click Included Content and 
under Choose a type of content, click on Page based 
on Schedule, and click Finish. 

3. Type in the URL of the page to appear during the 
scheduled time or click Browse and navigate to the 
file (Figure 9, 1). 

4. The next text box gives you the option to have an-
other page show before and after the  
scheduled time.   

5. Give the rule a starting (Figure 9, 2) and ending 
(Figure 9, 3) date and time.  Click OK to have the rule 
take affect. 

Page Banner 
A page banner can be added to your page as long as the webpage to have the page banner displayed 
on it has been added to the navigation.  To add a Page Banner to your website: 

1. Click Insert in the menu bar and choose Web Component. 

2. Under Component Type, click Included Content and under Choose a type of content, click 
on Page Banner. 

3. Make sure the page has been added to your navigation.  If so, you can select whether the page 
banner is a picture or text.  Type in the text if that is what you are adding and click OK. 

Link Bars 
Link bars, similar to interactive buttons, are linked buttons automatically formatted.  Interactive  
buttons can be placed anywhere on the page.  Links bars will be aligned at the top or left and are  
automatically formatted in row.  To add a link bar: 

 

Bar With Custom Links 
1. Go to the Insert menu and click Web Component.  Under Component Type, click Link Bars, 

and under Choose a bar type, click on Bar with custom links.  Click Next. 

2. Scroll down to choose a bar style, left click one time on the 
style you chose and click Next. 

3. Click on where you would like your link bar to be placed, 
on top or on the left and click Finish. 

4. Choose an existing link bar by clicking on the drop down 
arrow (Figure 10, 1) OR 

5. To create a new link bar, click the Create new button 
(Figure 10, 2). 

6. Click the Add link button to add another link to the bar 

Figure 9 
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7. In the text to display text box at the top, type in the text you want visitors to the site to see. 

8. Browse to a file or type in a URL in the Address text box. 

9. You can remove, modify, or move links from this menu.  Click OK to launch the link bar. 

10. Double click on Add Link to make future changes. 

Bar With Back and Next Links 
A bar with back and next links is different from a bar with custom links.  A bar with back and next 
links creates a linear series of links.  By clicking the back button, you arrive at the previous page.  
The previous page and the rest of the order the pages appear in is determined by the webpage  
creator.  To insert a bar with back and next links: 

1. Go to the Insert menu and click on Web Component.   

2. Under Insert Web Component, click on Link Bars.  Under Choose a bar type, click on Bar with 
back and next links, and click Next. 

3. Scroll down and choose a theme for the buttons. 

4. Under choose an orientation, decide whether to align the buttons at the top or left side. 

5. Choose an existing link bar by clicking on the drop down arrow (Figure 10, 1) OR 

6. To create a new link bar, click the Create new button (Figure 10, 2). 

7. Click the Add link button to add another link to the bar. 

8. In the Text To Display text box at the top, type in the text you want visitors to the site to see. 

9. Browse to a file or type in a URL in the Address text box. 

10. You can remove, modify, or move links from this menu.  Click OK to launch the link bar. 

11. Double click on Add Link to make future changes. 

You must include the page you are adding a bar with back and next links to in the link bar properties 
in order for the buttons to work. 

Bar based on Navigation Structure 
1. Go to the Insert menu and click on Web Component. 

2. Under Component type, choose Link Bars and under Choose a bar type, click on Bar based 
on a navigation structure.  Click Next. 

3. Scroll down and choose a bar style.  Click Next to continue. 

4. Choose an orientation, how you want the navigation aligned, either at the top of left side and 
click Finish. 

5. The Link Bar Properties window should appear.  Choose which hyperlinks to add to the page.  If 
you wish to change the style, click on the Style tab. 

6. Click OK to insert the link bar. 

Table of Contents 
A table of contents previews the topics covered in the document.  In a website, the table of contents 
provides links to the pages in a site.  To insert a table of contents: 

For This Web Site 
1. Go to the Insert menu and click on Web  

Component. 

2. Under Component type, choose Table of Contents 
and under Choose a table of contents, click on For 
this Web Site and click Finish. 

3. The Table of Contents Properties window will now 
open.  Verify your starting webpage is in the Page  
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URL for start point of table text box.   

4. Choose a font size.  The lower the number, the larger the text. 

5. Click OK. 

Based on Page Category 
1. Go to the Insert menu and click on Web Component. 

2. Under Component type, choose Table of Contents and under 
Choose a bar type, click on Based on Page Category.  Click 
Finish. 

3. Place checkmarks in the boxes to which you want to sort your 
web pages by (Figure 11, 1). 

4. Choose whether to sort the contents by Document Title or 
Date Last Modified. 

5. Click OK to insert the table of contents. 

 

Top 10 List 
Top ten lists will show the top ten of the following statistics  
on a web page: Visited Pages, Referring Domains,  
Referring URLs, Visiting Users, Operating Systems,  
Browser.  To insert a Top 10 List: 

1. Go to the Insert menu and click on Web Component. 

2. Under Component type, choose Top 10 List and under 
Choose a usage list, click on the  
statistic you would like displayed.  Click Finish. 

3. The Top 10 List Properties list will now appear.  Enter a 
title into the Title Text text box. 

4. Under List Style, choose a layout for the Top 10 
List. 

5. Click OK to insert the list. 

 
 

The process is the same for all of the types of Top 10 Lists. 

 

 

MSN Mapping Components 
Insert a Map 
Microsoft FrontPage provides the ability to add a map of a location to a webpage.  To add a map to a 
webpage: 

1. Go to the Insert menu and click on Web Component. 

2. Under Component type, choose MSN Mapping Components. 

3. Under Choose an MSN Mapping Component choose Insert a map and click Finish. 

4. Enter a street address, city, state, and zip code.  Click Next. 

5. Preview the map.  If this is correct, click Next. 

6. Click Finish. 

 

Figure 11 
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Link to a Map 
See page 9, Insert a map.  The process is the same.  Instead of inserting a preview of the map on 
the website, it inserts the address hyperlinked to MSN Maps for users to receive directions. 

MSN Components 
Microsoft includes two helpful tools for users to insert onto their webpage.  MSN search allows  
visitors to the site to perform a search of the internet via MSN.  MSN stock quote allows visitors to 
the site to search a stock quote via MSN.  To insert these tools: 

MSN Search 
1. Go to the Insert menu and click on Web Component. 

2. Under Component type, choose MSN Component and under Choose a MSN Component, 
click on Search the Web with MSN.  Click Finish to insert the MSN search tool. 

MSN Stock quote 
1. Go to the Insert menu and click on Web Component. 

2. Under Component type, choose MSN Component and under Choose a MSN Component, 
click on Stock Quote.  Click Finish to insert the MSN search tool. 

MSNBC Components 
Microsoft includes links to its headlines which can be added onto your webpage in the form of a 
linked picture.  The following headlines can be linked to: Business, Living and Travel, News, Sports, 
Technology, and Weather.  To insert a linked picture: 

1. Go to the Insert menu and click on Web Component. 

2. Under Component type, choose MSNBC Component and under MSNBC Component, click on 
the choice you want to insert.  Click Finish to insert the MSNBC Component. 
 

Weather requires you to enter the zip code of the city you would like local weather.  Enter the zip 
code and click Next to insert a local weather link similar to the one below. 


